Студопедия

КАТЕГОРИИ:


Архитектура-(3434)Астрономия-(809)Биология-(7483)Биотехнологии-(1457)Военное дело-(14632)Высокие технологии-(1363)География-(913)Геология-(1438)Государство-(451)Демография-(1065)Дом-(47672)Журналистика и СМИ-(912)Изобретательство-(14524)Иностранные языки-(4268)Информатика-(17799)Искусство-(1338)История-(13644)Компьютеры-(11121)Косметика-(55)Кулинария-(373)Культура-(8427)Лингвистика-(374)Литература-(1642)Маркетинг-(23702)Математика-(16968)Машиностроение-(1700)Медицина-(12668)Менеджмент-(24684)Механика-(15423)Науковедение-(506)Образование-(11852)Охрана труда-(3308)Педагогика-(5571)Полиграфия-(1312)Политика-(7869)Право-(5454)Приборостроение-(1369)Программирование-(2801)Производство-(97182)Промышленность-(8706)Психология-(18388)Религия-(3217)Связь-(10668)Сельское хозяйство-(299)Социология-(6455)Спорт-(42831)Строительство-(4793)Торговля-(5050)Транспорт-(2929)Туризм-(1568)Физика-(3942)Философия-(17015)Финансы-(26596)Химия-(22929)Экология-(12095)Экономика-(9961)Электроника-(8441)Электротехника-(4623)Энергетика-(12629)Юриспруденция-(1492)Ядерная техника-(1748)

И(условие1;условие2)


Помощь в написании учебных работ
1500+ квалифицированных специалистов готовы вам помочь

ИЛИ(условие1;условие2)

ЕСЛИ(условие;значение1;значение2)

 

Эта функция возвращает "значение1", если "условие" выполняется (истинно), и "значение2", если "условие" не выполняется (ложно).

Условие - это конструкция вида:

 

формула1 операция_отношения формула2

 

Например, B3+5<=C3

 

Значение - это либо формула, либо новая функция ЕСЛИ.

Например, для реализации конструкции

Y=

формулу можно записать так:

=ЕСЛИ(C5=0;0;MAX(D2:D10)/C5)

 

Для реализации конструкции

y= , т.е. y=ïA2ï ,

формулу можно записать так:

=ЕСЛИ(A2<0;-A2;ЕСЛИ(A2=0;0;A2)).

 

Следующие функции реализуют логические операции и предназначены для записи условий более сложного вида.

 

Функция для записи логического сложения имеет вид:

 

Функция ИЛИ() возвращает значение "ИСТИНА", если истинно либо "условие1", либо "условие2", либо истинны они оба. Если же оба этих условия ложны, то функция ИЛИ() возвращает значение "ЛОЖЬ".

Например, формула =ЕСЛИ(ИЛИ(A5>3; C3<>0);D3;E3) принимает значение клетки D3, если либо оба, либо одно из условий A5>3 и C3¹0 выполняются, в противном случае значением формулы является значение ячейки E3.

 

Функция для записи логического умножения имеет вид:

 

 

Функция И() возвращает значение "ИСТИНА", если "условие1" и "условие2" истинны одновременно. Если же хоть одно из них ложно, то функция И() возвращает значение "ЛОЖЬ".

Например, формула =ЕСЛИ(И(D4<E4;F4>0);5%*D4;0) принимает значение 0.05*D4, если условия D4<E4 и F4>0 выполняются одновременно, в противном случае значением формулы является число 0.

 

Функция логического отрицания имеет вид:

 

<== предыдущая лекция | следующая лекция ==>
Логические функции | Выделение элементов электронной таблицы

Дата добавления: 2013-12-13; Просмотров: 265; Нарушение авторских прав?;


Нам важно ваше мнение! Был ли полезен опубликованный материал? Да | Нет



ПОИСК ПО САЙТУ:


Читайте также:

    studopedia.su - Студопедия (2013 - 2022) год. Все материалы представленные на сайте исключительно с целью ознакомления читателями и не преследуют коммерческих целей или нарушение авторских прав! Последнее добавление




    Генерация страницы за: 0.017 сек.