Студопедия

КАТЕГОРИИ:


Архитектура-(3434)Астрономия-(809)Биология-(7483)Биотехнологии-(1457)Военное дело-(14632)Высокие технологии-(1363)География-(913)Геология-(1438)Государство-(451)Демография-(1065)Дом-(47672)Журналистика и СМИ-(912)Изобретательство-(14524)Иностранные языки-(4268)Информатика-(17799)Искусство-(1338)История-(13644)Компьютеры-(11121)Косметика-(55)Кулинария-(373)Культура-(8427)Лингвистика-(374)Литература-(1642)Маркетинг-(23702)Математика-(16968)Машиностроение-(1700)Медицина-(12668)Менеджмент-(24684)Механика-(15423)Науковедение-(506)Образование-(11852)Охрана труда-(3308)Педагогика-(5571)Полиграфия-(1312)Политика-(7869)Право-(5454)Приборостроение-(1369)Программирование-(2801)Производство-(97182)Промышленность-(8706)Психология-(18388)Религия-(3217)Связь-(10668)Сельское хозяйство-(299)Социология-(6455)Спорт-(42831)Строительство-(4793)Торговля-(5050)Транспорт-(2929)Туризм-(1568)Физика-(3942)Философия-(17015)Финансы-(26596)Химия-(22929)Экология-(12095)Экономика-(9961)Электроника-(8441)Электротехника-(4623)Энергетика-(12629)Юриспруденция-(1492)Ядерная техника-(1748)

А б в г д




Рис. 5.14. Приклади формування критеріїв

 

Умови можна задавати не тільки числові, а також текстові. При завданні текстових умов треба пам'ятати наступні правила:

  • одна буква означає, що потрібно знайти всі значення, що починаються з цієї букви;
  • знак " >" або " <" означає, що потрібно знайти всі значення, що знаходяться за алфавітом після або перед уведеною літерою.

Крім того можна задавати умови для часу, дати а також логічні умови.

Примітка. Якщо вихідні дані повинні містити тільки окремі поля первісної таблиці, то в діапазоні вихідних даних (результатів фільтрації) повинні бути зазначені заголовки тільки цих полів (ввести шляхом копіювання), а у вікні Расширенный фильтртреба водити у поле Поместить результат в диапазон тільки діапазон цих заголовків (приклад 2).

Приклад 2 .Для таблиці (Рис. 5.2) витягти прізвища і телефони менеджерів. При цьому вихідний діапазон визначиться як a1:f6.

 

Рис. 5.15. Використання розширеного фільтру.

Критерій заданий діапазоном h1:h2, діапазон заголовків результату - b10:c10, результатом фільтрації є дані в осередках b11:c12 (Рис. 15).

 

До результатів розширеної фільтрації може бути застосовна функція
ПРОМЕЖУТОЧНЫЕ.ИТОГИ так само, як і для автофільтру. При використанні розширеного фільтра можна використовувати умови, що обчислюються, тобто значення, що повертаються формулою.

Створення цих умов вимагає виконання наступних правил:

  • заголовок над умовою, що обчислюється, повинний відрізнятися від будь-якого заголовка стовпця в списку (він може бути порожнім чи містити довільний текст);
  • посилання на осередки, що знаходяться поза списком, повинні бути абсолютними;
  • посилання на осередки в списку повинні бути відносними.

 

Наприклад, для списку (Рис. 2) необхідно знайти всіх співробітників, у яких заробітна плата більше середнього окладу. Нехай у клітинку H1 записана формула =СРЗНАЧ(D2:D7), а в осередках Н2:Н3 введена умова, що обчислюється (Рис.16).

Рис. 5.16. Підготовка даних використання функції ПРОМЕЖУТОЧНЫЕ.ИТОГИ до результатів розширеної фільтрації.



 

Результат такої фільтрації на місці вихідних даних представлений на Рис. 17.

Рис. 5.17. Результат використання функції ПРОМЕЖУТОЧНЫЕ.ИТОГИ до результатів розширеної фільтрації.

 

 

5.1.6.3. Використання функцій СУММЕСЛИ і СЧЁТЕСЛИ

Дані функції дозволяють задавати критерії безпосередньо у формулі.

Функція СЧЁТЕСЛИ має наступний синтаксис:

=СЧЁТЕСЛИ(діапазон;критерій)

, де діапазон - це діапазон, у якому потрібно підрахувати кількість значень, а критерій- це текстове значення, що задає умова.
Так, для підрахунку числа співробітниць у списку (Рис. 2) можна використовувати функцію =СЧЁТЕСЛИ(E2:E7;"ж") . Функція поверне результат 3.

Функція СУММЕСЛИ має синтаксис:

=СУММЕСЛИ(диапазон; критерий; диапазон_суммирования)

, де критерий - умова, застосовувана до діапазону, а диапазон_суммирования задає діапазон значень, яки підсумовуються.

 

Так, для підрахунку сумарного окладу, одержуваного чоловіками, для списку (Рис. 2) можна використовувати функцію =СУММЕСЛИ(E2:E7;"м";D2:D7). Функція поверне результат 1550.

КОНТРОЛЬНІ ПИТАННЯ.

1. Що таке список у Excel?

2. Які можливості по редагуванню баз даних надає команда ФОРМА ?

3. Які критерії можна задавати в команді ФОРМА ?

4. Для чого потрібна сортування записів і як її здійснити ?

5. Як задати порядок вторинного сортування ?

6. Як відсортувати тільки один стовпець у таблиці ?

7. Як здійснити сортування по рядках ?

8. Чи розрізняються верхній і нижній регістр при сортуванні ?

9. Що можна зробити за допомогою команди АВТОФИЛЬТР ?

10. Які параметри потрібно установити щоб дані вибиралися при одночасному виконанні двох умов?

11. Які параметри потрібно установити щоб дані вибиралися при виконанні хоча б одного з двох умов?

12. Що можна зробити за допомогою команди РАСШИРЕННЫЙ ФИЛЬТР ?

 





Дата добавления: 2014-11-29; Просмотров: 537; Нарушение авторских прав?;


Нам важно ваше мнение! Был ли полезен опубликованный материал? Да | Нет



ПОИСК ПО САЙТУ:


studopedia.su - Студопедия (2013 - 2022) год. Все материалы представленные на сайте исключительно с целью ознакомления читателями и не преследуют коммерческих целей или нарушение авторских прав! Последнее добавление
Генерация страницы за: 0.019 сек.